Firefox/Seamonkey/Thunderbird Vulnerabilities

Patches are out for Firefox, Seamonkey and Thunderbird to resolve vulnerabilities that would allow credential theft, information disclosure, and arbitrary code execution
These issues are present in:
Firefox 3.0.3 and prior
Firefox 2.0.0.17 and prior
Thunderbird: 2.0.0.17 and prior
SeaMonkey 1.1.12 and prior