Firefox 2.0.16 and 3.0.1 released

Firefox 2.0.16 and 3.0.1 is out to fix the following security vulnerabilities.
MFSA 2008-35 Command-line URLs launch multiple tabs when Firefox not running
MFSA 2008-34 Remote code execution by overflowing CSS reference counter
UPDATE – looks like 3.0.1 isn’t out just yet. Keep your eyes open for it. http://www.mozilla.org/security/known-vulnerabilities/firefox30.html