New Adobe Flash Vulnerability

There were multiple reports today of an unpatched Adobe Flash vulnerability currently being exploited.
Symantec Bugtraq reports that this exploitation is fairly widespread.SQL injection has been used to insert code onto otherwise legitimate websites that results malware loading to exploit Flash.
Not a lot to be done. You could crawl into the Firefox/noscript cave. I’d suggest having that as an option, but in general keep the antivirus updated and make sure you you’re Flash is patched so you aren’t exploited by old attacks. Buckle your safety belts it could get bumpy.
UPDATE:
Further reports indicate that this is not a zero day vulnerability. It is exploiting unpatched versions of Flash. Make sure every browser installed is running the current version of flash. IE and Mozilla based browsers use a different Flash install.