Symantec Liveupdate November 21

I noticed today that Liveupdate on my home computer wasn’t working. The definitions were at November 21, 2007. When I attempted to run liveupdate manually I received an error ” LU1825: LiveUpdate could not understand how to install this update. You may need to get the latest version of LiveUpdate before you can install this update.”
I’d previously been following threads about this problem over at Broadband Reports and at the Symantec Forums.
I followed the advice here to either reboot or restart the Symantec Antivirus service. I restarted the SAV service and immediately liveupdate worked. I’ve had this problem on SAVCE 10.1.6 and 10.0.1, but I’ve seen postings from users of Symantec AV consumer products as well.