Lsoft Web Interface Vulnerable

Last week a vulnerability was announced in the web interface for Listserv. If you have Lsoft Listserv with a publicly available web interface, you should be looking at patches.
http://www.lsoft.com/news/securityadvisory2005-05.asp
http://www.securityfocus.com/archive/1/398919/2005-05-23/2005-05-29/0
Unlike some vendors who provide customers with large support Windows and supports older versions, you will have to upgrade to the latest version of Listserv to be able to patch.
This risk to this vulnerability can be somewhat mitigated by restricting who can access the web interface by IP address.