Zero to 3 Bugs in 12 hours

Netscape 8.0 was replaced by 8.0.1 hours after its release as several vulnerabilities were found. The vulnerabilities would reportedly allow a an attacker to attack arbitrary code if the user went to the attackers malicious site. What is really sad is it appears that these are known vulnerabilities in the Gecko engine that Firefox patched on May 6th.
Netscape requires a uninstall to be able to install a non-vulnerable version.
Security Pipeline
Netscape Vulnerabilities